Creating your first
flow using Claris
Connect

Introducing Claris Connect

Claris Connect™ is a cloud-based integration platform that allows you to create entire workflows
by connecting applications.

Claris Connect is built on the concept of flows, used to automate everyday business tasks and
processes.

Useful terms to know

The following terms will be useful to understand as you become more familiar with Claris Connect.

Term Description
Flow A workflow that connects two or more apps or utilities within a project
Project A set of related flows

Connector  Software the integrates workflows and shared data between apps or data sources

Action A step that carries out a specific operation on a target application
Trigger An event or action that initiates a flow
Step Any operation in a flow - such as triggers, actions, if-then, stop, and on-error

Step data Actual data returned from a previous step or preview data

Creating your first flow in Claris Connect

This document provides a step-by-step tutorial for creating a simple flow between two applications
- Mailchimp and Slack
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In this example, you will create a flow that checks to see if a new subscriber has been added to a
Mailchimp list and if so, a message will be generated and posted to Slack.

€ A

When a new subscriber is ...a message is generated /
added to Mailchimp... displayed in Slack

Before you begin

You will need accounts for both Mailchimp and Slack to follow along in this example. If you do not
have accounts for these services, you can sign up for a free account for either service. In addition:

e Create a new audience in Mailchimp. An audience is a place for you to collect and manage your
contacts in Mailchimp. In this example, the audience is named “Sample Audience."

¢ Create a new channel in Slack. A channelis a single place for a team to share messages, tools,
and files. In our example, the Slack channel is named “Sample_Slack_Channel.”

Step by step directions

STEP 1 - Create a new Project

Begin by creating a project. GarsGomect =
A project is an organizing container for your
flows. You work with projects on the Claris
Connect homepage, where you create projects
and use a project’s options menu to create, .
rename, or delete a project.

On the Claris Connect homepage, click “+" and
then click Create New. Enter a project name
and click Create. In this example, we are using
“My Example Project” as the project name.
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STEP 2 - Create a new Flow

Add a flow to your new project.

Flows are automations that use two or more
components. A component can be a Claris
Connect utility or a connector to a third-party
application ("app”)

Create a New Flow

Click Create New Flow to begin creating a new
flow in your project. Give your new flow a name
and click Save. In this example, use “My
Example Flow" as the name of the flow.

STEP 3 - Select the app or utility to use as a trigger

Select the app or utility that you want to trigger GaroComect

.......... atons (1)

the flow. All flows begin with a trigger. Note A
that some apps and utilities cannot act as a -
trigger (they are used only as actions) .

box r -3
A trigger is an event that initiates a flow. A .
trigger has two essential elements: the u @ | ¢
component (utility or app) in which the flow E
starts and the event in the component that Mailchimp App pg—— 9 e
initiates the flow. When a configured flow el
detects its trigger event, the flow runs. © o &

For our example, scroll down to the Apps
section and click the Mailchimp app.

STEP 4 - Select the action you want the trigger to “look"” for

Triggers look for specific events. Each trigger Clars Connet
will have different events that it can look for. o My Exampl Projoct - My Examplo Flow

% Flows

© Approvals
& Webhooks I3
1

For our example, we want to take action when a
new Mailchimp subscriber is detected.

For Mailchimp, select New Subscriber and
then click Continue.
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STEP 5 - Connect to your Mailchimp account

NOTE: Mailchimp provides a freemium service
that you can use in this example.

You must authorize Claris Connect to use the
various apps it connects to. Depending on the
app, you might also be able to create an
account directly within Claris Connect.

Click Connect New Account link and log in with
your Mailchimp credentials to continue.

Claris Connect Guide  Hep

# Mypojects My Example Project > My Example Flow

€3 6= Edt  Hstory  Setings  Versions Ditied

© Approvals.

OIS o strtr

Select > Acton > Accoumt > Configure

STEP 6 - Verify that your Mailchimp account is selected

After confirming the account configuration, you
should receive a "Success” message that you
have successfully connected Claris Connect to
Mailchimp.

Depending on the app you are connecting to,
you might have to configure / select an account
within that app or service.

Select Mailchimp account and click Continue.

STEP 7 - Select a Mailchimp mailing list to use

Claris Connect Gude  Help

# Myprojects My Example Project > My Example Flow

G Ed Moy Setings  Versons ousies
© Approvals

5O ot

Seect > Actin > Account > Confiore

/ Malchimp account Added afow seconds ago.

mmmmmmmmmmmmm

Claris Connect will need to know what
Mailchimp audience to use / monitor.

In this example, we are going to use the
audience named “Sample Audience.”

NOTE: Configure audiences within the
Mailchimp service.

Choose “Sample Audience” to continue and
click Save.
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=3 65D Edit History. Settings Versions Olostted

© Approvals

BN s

Select > Acton > Account > Configue
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STEP 8 - Add (manually) a new Mailchimp subscriber

When you are prompted, perform the action in =~ ® = cw o s e v
the trigger app. In our example, you will need to  .voveeiiies

add manually, in Mailchimp, a new subscriber to
“"Sample Audience.”

Audience
Sample Audience

Your audience has 1contacts. 1 of these are subscribers.

Performing this action in the trigger app not
only tests the app connection to Claris Connect, s e s somims s ot
but it also returns sample / “step” data for use Add subscriber

in subsequent steps.

Feedback

Email Address *

Manually add a new subscriber to “Sample ek gisoesanplecom
Audience"” in Mailchimp. .

Jack

STEP 9 - Confirm “test” subscriber was received

If Step 8 is successful, you should receive a Glais Gonnect o
“Connect Complete” (or equivalent) message. o s My Example Project » My Exampl Flow
TR e s e s
If the connection is successful, click Save. P e
-

STEP 10 - Add an action to your flow

This step configures the utility or app to use if a Glarto Conneet o

trigger is detected - otherwise known as o pes My Example Project » My Example Flow

“configuring the action.” CinL e -
& Webhooks G 1 New Subscriber - Sample Audience ®

Click "Action” P> ¢ scicn

An action has the same four configuration steps o
as a trigger. In this case, we want to choose the
action to perform when a new Mailchimp

subscriber is detected.

Click Action to continue.

Page 5 of 10



STEP 11 - Select the app to perform an action in

Select the app or utility to use for the action Clars Gonnect .
step of the flow. o

Select Slack to continue.

)
B :
i@
r

GoogleMail  Google Maps A Maiparse Office 365

° > #
Padhe  mine  Oidmos  Shewe  Seat
Click "Slack'" ey .-.'." a ® T

Shopiy Stack stipe Tilo

Select the flow action from those listed. Clars Comnect
In our example, when a new subscriber is added
to Mailchimp, we want to post a message to Postiessage Bt/ 1=,
Slack.

Choose Post Message to continue.

STEP 13 - Connect to your Slack account

Much like what we did in Step 5, Claris Connect
must authenticate with the selected app or
utility before you can interact with it. oo

% Flows

ClarisConnq stslack [0 s —comutng v | cum e

Claris Connect is requesting permission to
© spprocy access the Firma a ¥ v Consulting Slack
& Webhookl workspace

In our example, this means you need to log into .
your Slack account and provide Claris ORI
Connection permission to interact with it. s s Comectbe sl o view?

Click Connect New Account and log into your
Slack account.

‘What will Claris Connect be able to do?

Perform actions as you
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STEP 14 - Confirm Slack account configuration

After confirming the account configuration, you
should receive a “Success"” message that you
have successfully connected Claris Connect to
Slack.

Depending on the app you are connecting to,
you might have to configure / select an account
within that app or service.

Select Slack account and click Continue.

STEP 15 - Configure Slack action

Claris Connect

# My Projects.
% Flows

© Approvals
& Webhooks

My Example Project > My Example Flow
B Mooy Setngs  Versens
AR
G posthesage

Seect > Actn > Account > Configure

 slackaccount

‘Connect New Account

ddeda few seconds ago.

Each action will have different things to
configure.

For Slack, configure Channel and Message.

See Steps 15a - 15d for more information.

STEP 15a - Configure Slack action (Channel)

Claris Connect

# My Projects
% Flows.

© Approvals
& Webhooks

My Example Project > My Example Flow

Edt  Hstoy  Settngs  Versions

R ——
it
G posessse

Select > Acton > Account > Configue

Channel”
Select the channel

Choose the appropriate Slack Channel from
your Slack account.

Select “sample_slack_channel” from the list of
available channels.

NOTE: If “sample_slack_channel” does not

exist, you will need to create it in your Slack
account before proceeding.

Page 7 of 10

Claris Connect
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© Approvals
& Webhooks
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Edt  Hstoy  Settngs  Versions

CRE L —
FUT—
Soct > con > Accout > Contrs

Channel”
Select the channel

Ql

Review and Tost




STEP 15b - Configure Slack action (Message)

The "Message” is what you want posted to your Claris Comnect —
Slack account when a new subscriber is
detected.

With the Mailchimp account configured already,
information from Mailchimp, such as the name
of the new subscriber, can be used in the
message posted to Slack.

Click the =4 button associated with Message
and then "1. Mailchimp (Sample Audience)
New Subscriber” to continue to Step 15c.

STEP 15c - Configure Slack action (Message)

You can see the sample data from Mailchimp to gasComect e
aid you in picking the fields and values for your
message.

In our example, we are displaying the
subscriber’s first name (FNAME) and last name
(LNAME) with space in between along with the

static string of "has been added to Mailchimp.” FNAVE & LNAME ——p> 523

All of this is constructed in the Message field of E— ‘
Claris Connect as shown in the screenshot to e

the right. Foiat

Choose FNAME and LNAME and any additional
customizations you want.

STEP 15d - Configure Slack action (Confirm Message and Save)

When you are done constructing your message, ClarisGomect .
it should look something like this (see
screenshot to the right).

You can come back and edit this step anytime
you want - including editing and customizing
the message posted to your Slack account.

m

Click Save to continue. s -
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STEP 16 - Review and Test

You can test entire flows or individual steps of a
flow using Claris Connect.

Claris Connget G Helo

# MyPojects My Example Project > My Example Flow
% Flows

As you configure a flow step, you can test it by -
selecting the step to test and clicking Review
and Test.

Review and Test

uuuuuuuuuuuuu

To see how your message will look in Slack,
click Post Message to view the configuration of
your Slack step (if it is not already open and
visible) and click Review and Test.

Your completed flow should look like this (see
screenshot at right.)

Claris Connect e e

A My Projects My Example Project > My Example Flow

9 . 4 &3 o e weoy  Setegs  Versons Enable Flow > @0 cues
A flow is disabled by default while you are -

creating it.

When you enable a flow, the flow runs whenever
the trigger occurs. Consider, for example,
disabling a flow if you do not want it to run while
troubleshooting it.

Use the Enable / Disable slider to enable your
flow and add a new subscriber in Mailchimp to
see a message posted to Slack.

Next steps in working with Claris Connect

Now that you have created your first flow in Claris Connect, you are ready to create your own
triggers, flows, and actions as well as learn about webhooks, variables, and other types of action
steps like If-ten, stop, and on-error. When you are planning your next Claris Connect project, flow
these general steps:

1. Determine the workflow you want to automate, including the apps to connect and the steps you
want to be performed. Write down a task statement, such as: “When a new subscriber is
added to Mailchimp, a message should be generated and displayed in Slack”

2. Plan the project and flow based on the task statement. For example:

¢ Decide to create a Mailchimp mailing list because the flow starts with Mailchimp
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e |dentify the trigger and action (or actions) in the flow. In this example, adding a new
subscriber to Mailchimp is the trigger, and generating or displaying a message in Slack in
the action

3. Identify any prerequisite tasks for the flow. These are steps external to Claris Connect. For
example:

* You need user accounts for each app that you want to connect. In this case, Mailchimp and
Slack accounts

¢ In Mailchimp, you must create a subscriber list
¢ |n Slack, you must create a channel

4. Create the project

5. Create and enable the flow

6. Test the flow
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documentation solely with a valid licensed copy of FileMaker software.
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any resemblance to existing persons, companies, email addresses, or URLs is purely coincidental.
Product credits are listed in the Acknowledgments documents provided with this software.
Documentation credits are listed in the Documentation Acknowledgments. Mention of third-party
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For more information, visit our website at https://www.claris.com
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